KAUPPA

SoLow

System requirements

 

Mac: OS X 10.11.6 or later

Not tested on macOS 11 (Big Sur)

Windows: 7-8 or 10

Released under MIT lisence

(c) Maija Anttila 2021